Poecilotheria metallica (Gooty Ornamental)

More
4 years 6 months ago #68380 by CASPER
:ohmy: :igiveup:

Hi everybody

I was so excited to see my P. Metallica mold this morning, but on closer inspection it looks like 2 of its legs did not mold properly. I took a pic with my mobile phone,but unfortunately the quality is poor. I am quite concerned as I have never seen this. I kept the enclosure at high humidity and room temperature at 26 degrees celcius. I am not sure what I did wrong or what's gonna happen to my baby. Its moving around fine and its only the toe parts that looks abnormal

Please help with some advice!!!!! :spider:
Attachments:

Please Log in to join the conversation.

More
4 years 6 months ago #68381 by Huzaifah
I think Panama posted a similar thread ,his h.minax had a similar problem ..I'm sure when it molts again the legs will re-generate.

I too had an incident with a p.metallica sling ,it molted with high humidity and got stuck and died ..
The following user(s) said Thank You: Uncle Charlie

Please Log in to join the conversation.

More
4 years 6 months ago #68383 by CASPER
:thumbsup:

Thank you for the advice. Do you have any idea what the best way is with these guys? Do they need regular misting and wettish substrate?

Please Log in to join the conversation.

More
4 years 6 months ago #68385 by Huzaifah
I've kept mine like any other pokie , damn substrate and perch just when they are molting I up the humidity or leave them infront of the humidifier ...
I'm not sure what was the problem ,but my other one molted perfectly fine
The following user(s) said Thank You: CASPER

Please Log in to join the conversation.

Time to create page: 0.238 seconds
Powered by Kunena Forum