Lampropelma violaceopes

More
3 years 2 months ago #73866 by Leon de Jager
Hi all.

I am looking for advice......

I have now lost my fourth, yes 1....2...3..4....L. violacepes.
All from different breeders, guys I got plenty of T's from who we all know, so the problem isn't there.

All my others thrive, I just can't seem to keep these guys alive. :igiveup: :igiveup:
I keep them the same as all my pokies, just with slightly higher humidity and a bit more moisture.
They do fine until about 4 or 5 cm and then ........ tickets.

Sad thing is since I started in the hobby it is one of the two I have most wanted in my collection.
That and a H. lividum.

Any advice will be greatly appreciated.

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #73867 by Jake
Sorry man.

Avics and H.maculata is my kryptonite of species.

Maybe try not putting so much effort into keeping them.

What are the parameters are you keeping them in?
Temps, humidity and what kind of setups?
Last Edit: 3 years 2 months ago by Jake.

Please Log in to join the conversation.

More
3 years 2 months ago #73868 by Huzaifah
ive kept mine with deeper substrate and allowed them to burrow ,also kept it slightly moist with occasional mistings ,have had no problems this way
The following user(s) said Thank You: Leon de Jager

Please Log in to join the conversation.

More
3 years 1 month ago #73876 by Leon de Jager
Thanks guys.
Sorry for the late reply, had a bit of trouble with my internet.
I keep them very similar to my pokies, temps between 22 and 27 degrees, humidity about 70 percent.

Seeing as they were all still small, they had quite a bit of substrate.
Also kept in deli cups, therafter in the same enclosures I use for all my others. If you look at my pictures you can get an idea of them.

Like you said Jake, maybe they just are my kryptonite...
Maybe I must try the H.lividum

Please Log in to join the conversation.

Time to create page: 0.312 seconds
Powered by Kunena Forum